4.1 Introduction

Welcome to the Atmel AVR Assembler. This manual describes the usage of the Assembler. The Assembler covers the whole range of microcontrollers in the AT90S family.

The Assembler translates assembly source code into object code. The generated object code can be used as input to a simulator or an emulator such as the Atmel AVR In-Circuit Emulator. The Assembler also generates a PROMable code and an optional EEPROM file which can be programmed directly into the program memory and EEPROM memory of an AVR microcontroller.

The Assembler generates fixed code allocations, consequently no linking is necessary.

The Assembler runs under Microsoft Windows 3.11, Microsoft Windows95 and Microsoft Windows NT. In addition, there is an MS-DOS command line version. The Windows version of the program contains an on-line help function covering most of this document.

The instruction set of the AVR family of microcontrollers is only briefly described, refer to the AVR Data Book (also available on CD-ROM) in order to get more detailed knowledge of the instruction set for the different microcontrollers.

To get quickly started, the Quick-Start Tutorial is an easy way to get familiar with the Atmel AVR Assembler.
This tutorial assumes that the AVR Assembler and all program files that come with it are properly installed on your computer. Please refer to the installation instructions.

Start the AVR Assembler. By selecting "File → Open" from the menu or by clicking on the toolbar, open the file “tutor1.asm”. This loads the assembly file into the Editor window. Read the program header and take a look at the program but do not make any changes yet.

Once you have had a look at the program, select Assemble from the menu. A second window (the Message window) appears, containing a lot of error messages. This window will overlap the editor window, so it is a good idea to clean up your work space on the screen. Select the Editor window containing the program code, and select “Window → Tile Horizontal” from the menu. It is useful to have the Editor window larger than the Message window, so move the top of the Message window down a bit, and follow with the bottom of the Editor window. Your screen should look like this:
Finding and Correcting Errors

From the looks of the Message window, it seems that you have attempted to assemble a program with lots of bugs. To get any further, the errors must be found and corrected. Point to the first error message in the Message window (the one reported to be on line 54) and press the left mouse button. Notice that in the Editor window, a red vertical bar is displayed all over line 54. The error message says that only registers R0 to R31 can be assigned variable names. That is true since the AVR has exactly 32 General Purpose working registers numbered R0-R31, and “tutor1.asm” tries to assign a name to register 32. See the figure below.

Double click on the error message in the Message window and observe that the Editor window becomes active while the cursor is positioned at the start of the line containing the error. Correct the mistake by changing “r32” to “r19” in the Editor window. One down, five to go.

Now click on the next error in the list. The message “Illegal argument type or count”, tells that something is wrong with the arguments following the compare (“cp”) instruction. Notice that the register named “BH” is one of the arguments, which happens to be the variable we just corrected. By clicking along on the remaining errors, it appears that the first error generated all the messages.

Reassembling

To find out whether all errors have been corrected, double click on any error (to activate the Editor window) or click inside the Editor window before you assemble once more. If you have done it all right up till now, the Message window will tell that you are crowned with success.
4.3 Assembler source

The Assembler works on source files containing instruction mnemonics, labels and directives. The instruction mnemonics and the directives often take operands.

Code lines should be limited to 120 characters.

Every input line can be preceded by a label, which is an alphanumeric string terminated by a colon. Labels are used as targets for jump and branch instructions and as variable names in Program memory and RAM.

An input line may take one of the four following forms:

1. `[label:] directive [operands] [Comment]`
2. `[label:] instruction [operands] [Comment]`
3. Comment
4. Empty line

A comment has the following form:

`; [Text]`

Items placed in braces are optional. The text between the comment-delimiter (;) and the end of line (EOL) is ignored by the Assembler. Labels, instructions and directives are described in more detail later.

Examples:

```
label: .EQU var1=100 ; Set var1 to 100 (Directive)
       .EQU var2=200 ; Set var2 to 200

test: rjmp test ; Infinite loop (Instruction)
       ; Pure comment line
       ; Another comment line
```

Note: There are no restrictions with respect to column placement of labels, directives, comments or instructions.
4.4 Instruction mnemonics

The Assembler accepts mnemonic instructions from the instruction set. A summary of the instruction set mnemonics and their parameters is given here. For a detailed description of the Instruction set, refer to the AVR Data Book.

<table>
<thead>
<tr>
<th>Mnemonics</th>
<th>Operands</th>
<th>Description</th>
<th>Operation</th>
<th>Flags</th>
<th>#Clock Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADD</td>
<td>Rd, Rr</td>
<td>Add without Carry</td>
<td>Rd ← Rd + Rr</td>
<td>Z,C,N,V,H</td>
<td>1</td>
</tr>
<tr>
<td>ADC</td>
<td>Rd, Rr</td>
<td>Add with Carry</td>
<td>Rd ← Rd + Rr + C</td>
<td>Z,C,N,V,H</td>
<td>1</td>
</tr>
<tr>
<td>ADIW</td>
<td>Rd, K</td>
<td>Add Immediate to Word</td>
<td>Rd+1:Rd ← Rd+1:Rd + K</td>
<td>Z,C,N,V</td>
<td>2</td>
</tr>
<tr>
<td>SUB</td>
<td>Rd, Rr</td>
<td>Subtract without Carry</td>
<td>Rd ← Rd - Rr</td>
<td>Z,C,N,V,H</td>
<td>1</td>
</tr>
<tr>
<td>SUBI</td>
<td>Rd, K</td>
<td>Subtract Immediate</td>
<td>Rd ← Rd - K</td>
<td>Z,C,N,V,H</td>
<td>1</td>
</tr>
<tr>
<td>SBC</td>
<td>Rd, Rr</td>
<td>Subtract with Carry</td>
<td>Rd ← Rd - Rr - C</td>
<td>Z,C,N,V,H</td>
<td>1</td>
</tr>
<tr>
<td>SBCI</td>
<td>Rd, K</td>
<td>Subtract Immediate with Carry</td>
<td>Rd ← Rd - K - C</td>
<td>Z,C,N,V,H</td>
<td>1</td>
</tr>
<tr>
<td>SBIW</td>
<td>Rd, K</td>
<td>Subtract Immediate from Word</td>
<td>Rd+1:Rd ← Rd+1:Rd - K</td>
<td>Z,C,N,V</td>
<td>2</td>
</tr>
<tr>
<td>AND</td>
<td>Rd, Rr</td>
<td>Logical AND</td>
<td>Rd ← Rd • Rr</td>
<td>Z,N,V</td>
<td>1</td>
</tr>
<tr>
<td>ANDI</td>
<td>Rd, K</td>
<td>Logical AND with Immediate</td>
<td>Rd ← Rd • K</td>
<td>Z,N,V</td>
<td>1</td>
</tr>
<tr>
<td>OR</td>
<td>Rd, Rr</td>
<td>Logical OR</td>
<td>Rd ← Rd v Rr</td>
<td>Z,N,V</td>
<td>1</td>
</tr>
<tr>
<td>ORI</td>
<td>Rd, K</td>
<td>Logical OR with Immediate</td>
<td>Rd ← Rd v K</td>
<td>Z,N,V</td>
<td>1</td>
</tr>
<tr>
<td>EOR</td>
<td>Rd, Rr</td>
<td>Exclusive OR</td>
<td>Rd ← Rd ⊕ Rr</td>
<td>Z,N,V</td>
<td>1</td>
</tr>
<tr>
<td>COM</td>
<td>Rd</td>
<td>One's Complement</td>
<td>Rd ← $FF - Rd</td>
<td>Z,C,N,V</td>
<td>1</td>
</tr>
<tr>
<td>NEG</td>
<td>Rd</td>
<td>Two's Complement</td>
<td>Rd ← $00 - Rd</td>
<td>Z,C,N,V,H</td>
<td>1</td>
</tr>
<tr>
<td>SBR</td>
<td>Rd,K</td>
<td>Set Bit(s) in Register</td>
<td>Rd ← Rd v K</td>
<td>Z,N,V</td>
<td>1</td>
</tr>
<tr>
<td>CBR</td>
<td>Rd,K</td>
<td>Clear Bit(s) in Register</td>
<td>Rd ← Rd • ($FFh - K)</td>
<td>Z,N,V</td>
<td>1</td>
</tr>
<tr>
<td>INC</td>
<td>Rd</td>
<td>Increment</td>
<td>Rd ← Rd + 1</td>
<td>Z,N,V</td>
<td>1</td>
</tr>
<tr>
<td>DEC</td>
<td>Rd</td>
<td>Decrement</td>
<td>Rd ← Rd - 1</td>
<td>Z,N,V</td>
<td>1</td>
</tr>
<tr>
<td>TST</td>
<td>Rd</td>
<td>Test for Zero or Minus</td>
<td>Rd ← Rd • Rd</td>
<td>Z,N,V</td>
<td>1</td>
</tr>
<tr>
<td>CLR</td>
<td>Rd</td>
<td>Clear Register</td>
<td>Rd ← Rd ⊕ Rd</td>
<td>Z,N,V</td>
<td>1</td>
</tr>
<tr>
<td>SER</td>
<td>Rd</td>
<td>Set Register</td>
<td>Rd ← $FF</td>
<td>None</td>
<td>1</td>
</tr>
<tr>
<td>MUL</td>
<td>Rd,Rr</td>
<td>Multiply Unsigned</td>
<td>R1, R0 ← Rd × Rr</td>
<td>C</td>
<td>2 (1)</td>
</tr>
</tbody>
</table>

Note: 1. Not available in base-line microcontrollers
## BRANCH INSTRUCTIONS

<table>
<thead>
<tr>
<th>Mnemonics</th>
<th>Operands</th>
<th>Description</th>
<th>Operation</th>
<th>Flags</th>
<th>#Clock Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>RJMP</td>
<td>k</td>
<td>Relative Jump</td>
<td>PC ← PC + k + 1</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>IJMP</td>
<td></td>
<td>Indirect Jump to (Z)</td>
<td>PC ← Z</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>JMP</td>
<td>k</td>
<td>Jump</td>
<td>PC ← k</td>
<td>None</td>
<td>3</td>
</tr>
<tr>
<td>RCALL</td>
<td>k</td>
<td>Relative Call Subroutine</td>
<td>PC ← PC + k + 1</td>
<td>None</td>
<td>3</td>
</tr>
<tr>
<td>ICALL</td>
<td>k</td>
<td>Indirect Call to (Z)</td>
<td>PC ← Z</td>
<td>None</td>
<td>3</td>
</tr>
<tr>
<td>CALL</td>
<td>k</td>
<td>Call Subroutine</td>
<td>PC ← k</td>
<td>None</td>
<td>4</td>
</tr>
<tr>
<td>RET</td>
<td></td>
<td>Subroutine Return</td>
<td>PC ← STACK</td>
<td>None</td>
<td>4</td>
</tr>
<tr>
<td>RETI</td>
<td></td>
<td>Interrupt Return</td>
<td>PC ← STACK</td>
<td>I</td>
<td>4</td>
</tr>
<tr>
<td>CPSE</td>
<td>Rd,Rr</td>
<td>Compare, Skip if Equal</td>
<td>if (Rd = Rr) then PC ← PC + 2 or 3</td>
<td>None</td>
<td>1 / 2 / 3</td>
</tr>
<tr>
<td>CP</td>
<td>Rd,Rr</td>
<td>Compare</td>
<td>Rd - Rr - C</td>
<td>Z,C,N,V,H</td>
<td>1</td>
</tr>
<tr>
<td>CPC</td>
<td>Rd,Rr</td>
<td>Compare with Carry</td>
<td>Rd - Rr - C</td>
<td>Z,C,N,V,H</td>
<td>1</td>
</tr>
<tr>
<td>CPI</td>
<td>Rd,K</td>
<td>Compare with Immediate</td>
<td>Rd - K</td>
<td>Z,C,N,V,H</td>
<td>1</td>
</tr>
<tr>
<td>SBRC</td>
<td>Rr, b</td>
<td>Skip if Bit in Register Cleared</td>
<td>if ((Rr(b)=0)) then PC ← PC + 2 or 3</td>
<td>None</td>
<td>1 / 2 / 3</td>
</tr>
<tr>
<td>SBRS</td>
<td>Rr, b</td>
<td>Skip if Bit in Register Set</td>
<td>if ((Rr(b)=1)) then PC ← PC + 2 or 3</td>
<td>None</td>
<td>1 / 2 / 3</td>
</tr>
<tr>
<td>SBIC</td>
<td>P, b</td>
<td>Skip if Bit in I/O Register Cleared</td>
<td>if ((I/O(Pb)=0)) then PC ← PC + 2 or 3</td>
<td>None</td>
<td>1 / 2 / 3</td>
</tr>
<tr>
<td>SBIS</td>
<td>P, b</td>
<td>Skip if Bit in I/O Register Set</td>
<td>if ((I/O(Pb)=1)) then PC ← PC + 2 or 3</td>
<td>None</td>
<td>1 / 2 / 3</td>
</tr>
<tr>
<td>BRBS</td>
<td>s, k</td>
<td>Branch if Status Flag Set</td>
<td>if ((SREG(s) = 1)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRBC</td>
<td>s, k</td>
<td>Branch if Status Flag Cleared</td>
<td>if ((SREG(s) = 0)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BREQ</td>
<td>k</td>
<td>Branch if Equal</td>
<td>if ((Z = 1)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRNE</td>
<td>k</td>
<td>Branch if Not Equal</td>
<td>if ((Z = 0)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRCS</td>
<td>k</td>
<td>Branch if Carry Set</td>
<td>if ((C = 1)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRCC</td>
<td>k</td>
<td>Branch if Carry Cleared</td>
<td>if ((C = 0)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRSH</td>
<td>k</td>
<td>Branch if Same or Higher</td>
<td>if ((C = 0)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRLO</td>
<td>k</td>
<td>Branch if Lower</td>
<td>if ((C = 1)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRMI</td>
<td>k</td>
<td>Branch if Minus</td>
<td>if ((N = 1)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRPL</td>
<td>k</td>
<td>Branch if Plus</td>
<td>if ((N = 0)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRGE</td>
<td>k</td>
<td>Branch if Greater or Equal, Signed</td>
<td>if ((N \oplus V = 0)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRLT</td>
<td>k</td>
<td>Branch if Less Than, Signed</td>
<td>if ((N \oplus V = 1)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRHS</td>
<td>k</td>
<td>Branch if Half Carry Flag Set</td>
<td>if ((H = 1)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRHC</td>
<td>k</td>
<td>Branch if Half Carry Flag Cleared</td>
<td>if ((H = 0)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRTS</td>
<td>k</td>
<td>Branch if T Flag Set</td>
<td>if ((T = 1)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRTC</td>
<td>k</td>
<td>Branch if T Flag Cleared</td>
<td>if ((T = 0)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRVS</td>
<td>k</td>
<td>Branch if Overflow Flag is Set</td>
<td>if ((V = 1)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRVC</td>
<td>k</td>
<td>Branch if Overflow Flag is Cleared</td>
<td>if ((V = 0)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRIE</td>
<td>k</td>
<td>Branch if Interrupt Enabled</td>
<td>if ((I = 1)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
<tr>
<td>BRID</td>
<td>k</td>
<td>Branch if Interrupt Disabled</td>
<td>if ((I = 0)) then PC ← PC + k + 1</td>
<td>None</td>
<td>1 / 2</td>
</tr>
</tbody>
</table>
### DATA TRANSFER INSTRUCTIONS

<table>
<thead>
<tr>
<th>Mnemonics</th>
<th>Operands</th>
<th>Description</th>
<th>Operation</th>
<th>Flags</th>
<th>#Clock Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>MOV</td>
<td>Rd, Rr</td>
<td>Copy Register</td>
<td>Rd ← Rr</td>
<td>None</td>
<td>1</td>
</tr>
<tr>
<td>LDI</td>
<td>Rd, K</td>
<td>Load Immediate</td>
<td>Rd ← K</td>
<td>None</td>
<td>1</td>
</tr>
<tr>
<td>LDS</td>
<td>Rd, k</td>
<td>Load Direct from SRAM</td>
<td>Rd ← (k)</td>
<td>None</td>
<td>3</td>
</tr>
<tr>
<td>LD</td>
<td>Rd, X</td>
<td>Load Indirect</td>
<td>Rd ← (X)</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>LD</td>
<td>Rd, X+</td>
<td>Load Indirect and Post-Increment</td>
<td>Rd ← (X), X ← X + 1</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>LD</td>
<td>Rd, -X</td>
<td>Load Indirect and Pre-Decrement</td>
<td>X ← X - 1, Rd ← (X)</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>LD</td>
<td>Rd, Y</td>
<td>Load Indirect</td>
<td>Rd ← (Y)</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>LD</td>
<td>Rd, Y+</td>
<td>Load Indirect and Post-Increment</td>
<td>Rd ← (Y), Y ← Y + 1</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>LDD</td>
<td>Rd, Y+q</td>
<td>Load Indirect with Displacement</td>
<td>Rd ← (Y + q)</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>LD</td>
<td>Rd, Z</td>
<td>Load Indirect</td>
<td>Rd ← (Z)</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>LD</td>
<td>Rd, Z+</td>
<td>Load Indirect and Post-Increment</td>
<td>Rd ← (Z), Z ← Z + 1</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>LDD</td>
<td>Rd, Z+q</td>
<td>Load Indirect with Displacement</td>
<td>Rd ← (Z + q)</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>STS</td>
<td>k, Rr</td>
<td>Store Direct to SRAM</td>
<td>(k) ← Rr</td>
<td>None</td>
<td>3</td>
</tr>
<tr>
<td>ST</td>
<td>X, Rr</td>
<td>Store Indirect</td>
<td>(X) ← Rr</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>ST</td>
<td>X+, Rr</td>
<td>Store Indirect and Post-Increment</td>
<td>(X) ← Rr, X ← X + 1</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>ST</td>
<td>-X, Rr</td>
<td>Store Indirect and Pre-Decrement</td>
<td>X ← X - 1, (X) ← Rr</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>ST</td>
<td>Y, Rr</td>
<td>Store Indirect</td>
<td>(Y) ← Rr</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>ST</td>
<td>Y+, Rr</td>
<td>Store Indirect and Post-Increment</td>
<td>(Y) ← Rr, Y ← Y + 1</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>ST</td>
<td>-Y, Rr</td>
<td>Store Indirect and Pre-Decrement</td>
<td>Y ← Y - 1, (Y) ← Rr</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>STD</td>
<td>Y+q, Rr</td>
<td>Store Indirect with Displacement</td>
<td>(Y + q) ← Rr</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>ST</td>
<td>Z, Rr</td>
<td>Store Indirect</td>
<td>(Z) ← Rr</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>ST</td>
<td>Z+, Rr</td>
<td>Store Indirect and Post-Increment</td>
<td>(Z) ← Rr, Z ← Z + 1</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>ST</td>
<td>-Z, Rr</td>
<td>Store Indirect and Pre-Decrement</td>
<td>Z ← Z - 1, (Z) ← Rr</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>STD</td>
<td>Z+q, Rr</td>
<td>Store Indirect with Displacement</td>
<td>(Z + q) ← Rr</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>LPM</td>
<td></td>
<td>Load Program Memory</td>
<td>R0 ← (Z)</td>
<td>None</td>
<td>3</td>
</tr>
<tr>
<td>IN</td>
<td>Rd, P</td>
<td>In Port</td>
<td>Rd ← P</td>
<td>None</td>
<td>1</td>
</tr>
<tr>
<td>OUT</td>
<td>P, Rr</td>
<td>Out Port</td>
<td>P ← Rr</td>
<td>None</td>
<td>1</td>
</tr>
<tr>
<td>PUSH</td>
<td>Rr</td>
<td>Push Register on Stack</td>
<td>STACK ← Rr</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>POP</td>
<td>Rd</td>
<td>Pop Register from Stack</td>
<td>Rd ← STACK</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>Mnemonics</td>
<td>Operands</td>
<td>Description</td>
<td>Operation</td>
<td>Flags</td>
<td>#Clock Note</td>
</tr>
<tr>
<td>-------------------</td>
<td>----------</td>
<td>---------------------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>BIT AND BIT-TEST INSTRUCTIONS</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>LSL</td>
<td>Rd</td>
<td>Logical Shift Left</td>
<td>Rd(n+1) ← Rd(n), Rd(0) ← 0, C ← Rd(7)</td>
<td>Z,C,N,V,H</td>
<td>1</td>
</tr>
<tr>
<td>LSR</td>
<td>Rd</td>
<td>Logical Shift Right</td>
<td>Rd(n) ← Rd(n+1), Rd(7) ← 0, C ← Rd(0)</td>
<td>Z,C,N,V</td>
<td>1</td>
</tr>
<tr>
<td>ROL</td>
<td>Rd</td>
<td>Rotate Left Through Carry</td>
<td>Rd(0) ← C, Rd(n+1) ← Rd(n), C ← Rd(7)</td>
<td>Z,C,N,V,H</td>
<td>1</td>
</tr>
<tr>
<td>ROR</td>
<td>Rd</td>
<td>Rotate Right Through Carry</td>
<td>Rd(7) ← C, Rd(n) ← Rd(n+1), C ← Rd(0)</td>
<td>Z,C,N,V</td>
<td>1</td>
</tr>
<tr>
<td>ASR</td>
<td>Rd</td>
<td>Arithmetic Shift Right</td>
<td>Rd(n) ← Rd(n+1), n=0..6</td>
<td>Z,C,N,V</td>
<td>1</td>
</tr>
<tr>
<td>SWAP</td>
<td>Rd</td>
<td>Swap Nibbles</td>
<td>Rd(3..0) ↔ Rd(7..4)</td>
<td>None</td>
<td>1</td>
</tr>
<tr>
<td>BSET</td>
<td>s</td>
<td>Flag Set</td>
<td>SREG(s) ← 1</td>
<td>SREG(s)</td>
<td>1</td>
</tr>
<tr>
<td>BCLR</td>
<td>s</td>
<td>Flag Clear</td>
<td>SREG(s) ← 0</td>
<td>SREG(s)</td>
<td>1</td>
</tr>
<tr>
<td>SBI</td>
<td>P, b</td>
<td>Set Bit in I/O Register</td>
<td>I/O(P, b) ← 1</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>CBI</td>
<td>P, b</td>
<td>Clear Bit in I/O Register</td>
<td>I/O(P, b) ← 0</td>
<td>None</td>
<td>2</td>
</tr>
<tr>
<td>BST</td>
<td>Rr, b</td>
<td>Bit Store from Register to T</td>
<td>T ← Rr(b)</td>
<td>T</td>
<td>1</td>
</tr>
<tr>
<td>BLD</td>
<td>Rd, b</td>
<td>Bit load from T to Register</td>
<td>Rd(b) ← T</td>
<td>None</td>
<td>1</td>
</tr>
<tr>
<td>SEC</td>
<td></td>
<td>Set Carry</td>
<td>C ← 1</td>
<td>C</td>
<td>1</td>
</tr>
<tr>
<td>CLC</td>
<td></td>
<td>Clear Carry</td>
<td>C ← 0</td>
<td>C</td>
<td>1</td>
</tr>
<tr>
<td>SEN</td>
<td></td>
<td>Set Negative Flag</td>
<td>N ← 1</td>
<td>N</td>
<td>1</td>
</tr>
<tr>
<td>CLN</td>
<td></td>
<td>Clear Negative Flag</td>
<td>N ← 0</td>
<td>N</td>
<td>1</td>
</tr>
<tr>
<td>SEZ</td>
<td></td>
<td>Set Zero Flag</td>
<td>Z ← 1</td>
<td>Z</td>
<td>1</td>
</tr>
<tr>
<td>CLZ</td>
<td></td>
<td>Clear Zero Flag</td>
<td>Z ← 0</td>
<td>Z</td>
<td>1</td>
</tr>
<tr>
<td>SEI</td>
<td></td>
<td>Global Interrupt Enable</td>
<td>I ← 1</td>
<td>I</td>
<td>1</td>
</tr>
<tr>
<td>CLI</td>
<td></td>
<td>Global Interrupt Disable</td>
<td>I ← 0</td>
<td>I</td>
<td>1</td>
</tr>
<tr>
<td>SES</td>
<td></td>
<td>Set Signed Test Flag</td>
<td>S ← 1</td>
<td>S</td>
<td>1</td>
</tr>
<tr>
<td>CLS</td>
<td></td>
<td>Clear Signed Test Flag</td>
<td>S ← 0</td>
<td>S</td>
<td>1</td>
</tr>
<tr>
<td>SEV</td>
<td></td>
<td>Set Two's Complement Overflow</td>
<td>V ← 1</td>
<td>V</td>
<td>1</td>
</tr>
<tr>
<td>CLV</td>
<td></td>
<td>Clear Two's Complement Overflow</td>
<td>V ← 0</td>
<td>V</td>
<td>1</td>
</tr>
<tr>
<td>SET</td>
<td></td>
<td>Set T in SREG</td>
<td>T ← 1</td>
<td>T</td>
<td>1</td>
</tr>
<tr>
<td>CLT</td>
<td></td>
<td>Clear T in SREG</td>
<td>T ← 0</td>
<td>T</td>
<td>1</td>
</tr>
<tr>
<td>SEH</td>
<td></td>
<td>Set Half Carry Flag in SREG</td>
<td>H ← 1</td>
<td>H</td>
<td>1</td>
</tr>
<tr>
<td>CLH</td>
<td></td>
<td>Clear Half Carry Flag in SREG</td>
<td>H ← 0</td>
<td>H</td>
<td>1</td>
</tr>
<tr>
<td>NOP</td>
<td></td>
<td>No Operation</td>
<td>None</td>
<td>None</td>
<td>1</td>
</tr>
<tr>
<td>SLEEP</td>
<td></td>
<td>Sleep</td>
<td>None</td>
<td>None</td>
<td>1</td>
</tr>
<tr>
<td>WDR</td>
<td></td>
<td>Watchdog Reset</td>
<td>None</td>
<td>None</td>
<td>1</td>
</tr>
</tbody>
</table>
The Assembler is not case sensitive.

The operands have the following forms:
- \( \text{Rd} \): R0-R31 or R16-R31 (depending on instruction)
- \( \text{Rr} \): R0-R31
- \( \text{b} \): Constant (0-7), can be a constant expression
- \( \text{s} \): Constant (0-7), can be a constant expression
- \( \text{P} \): Constant (0-31/63), can be a constant expression
- \( \text{K} \): Constant (0-255), can be a constant expression
- \( \text{k} \): Constant, value range depending on instruction. Can be a constant expression
- \( \text{q} \): Constant (0-63), can be a constant expression

## 4.5 Assembler directives

The Assembler supports a number of directives. The directives are not translated directly into opcodes. Instead, they are used to adjust the location of the program in memory, define macros, initialize memory and so on. An overview of the directives is given in the following table.

**Summary of directives:**

<table>
<thead>
<tr>
<th>Directive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BYTE</td>
<td>Reserve byte to a variable</td>
</tr>
<tr>
<td>CSEG</td>
<td>Code Segment</td>
</tr>
<tr>
<td>DB</td>
<td>Define constant byte(s)</td>
</tr>
<tr>
<td>DEF</td>
<td>Define a symbolic name on a register</td>
</tr>
<tr>
<td>DEVICE</td>
<td>Define which device to assemble for</td>
</tr>
<tr>
<td>DSEG</td>
<td>Data Segment</td>
</tr>
<tr>
<td>DW</td>
<td>Define constant word(s)</td>
</tr>
<tr>
<td>ENDMACRO</td>
<td>End macro</td>
</tr>
<tr>
<td>EQU</td>
<td>Set a symbol equal to an expression</td>
</tr>
<tr>
<td>ESEG</td>
<td>EEPROM Segment</td>
</tr>
<tr>
<td>EXIT</td>
<td>Exit from file</td>
</tr>
<tr>
<td>INCLUDE</td>
<td>Read source from another file</td>
</tr>
<tr>
<td>LIST</td>
<td>Turn listfile generation on</td>
</tr>
<tr>
<td>LISTMAC</td>
<td>Turn macro expansion on</td>
</tr>
<tr>
<td>MACRO</td>
<td>Begin macro</td>
</tr>
<tr>
<td>NOLIST</td>
<td>Turn listfile generation off</td>
</tr>
<tr>
<td>ORG</td>
<td>Set program origin</td>
</tr>
<tr>
<td>SET</td>
<td>Set a symbol to an expression</td>
</tr>
</tbody>
</table>

**Note:** All directives must be preceded by a period.
4.5.1 BYTE - Reserve bytes to a variable

The BYTE directive reserves memory resources in the SRAM. In order to be able to refer to the reserved location, the BYTE directive should be preceded by a label. The directive takes one parameter, which is the number of bytes to reserve. The directive can only be used within a Data Segment (see directives CSEG, DSEG and ESEG). Note that a parameter must be given. The allocated bytes are not initialized.

Syntax:

```
LABEL: .BYTE expression
```

Example:

```
.DSEG
var1: .BYTE 1 ; reserve 1 byte to var1
table: .BYTE tab_size ; reserve tab_size bytes
.CSEG
ldi r30,low(var1) ; Load Z register low
ldi r31,high(var1) ; Load Z register high
ld r1,Z ; Load VAR1 into register 1
```

4.5.2 CSEG - Code Segment

The CSEG directive defines the start of a Code Segment. An Assembler file can consist of several Code Segments, which are concatenated into one Code Segment when assembled. The BYTE directive cannot be used within a Code Segment. The default segment type is Code. The Code Segments have their own location counter which is a word counter. The ORG directive (see description later in this document) can be used to place code and constants at specific locations in the Program memory. The directive does not take any parameters.

Syntax:

```
.CSEG
```

Example:

```
.DSEG ; Start data segment
vartab: .BYTE 4 ; Reserve 4 bytes in SRAM
.CSEG ; Start code segment
const: .DW 2 ; Write 0x0002 in prog.mem.
mov r1,r0 ; Do something
```
4.5.3 **DB-Define constant byte(s) in program memory or E\textsuperscript{2}PROM memory**

The DB directive reserves memory resources in the program memory or the EEPROM memory. In order to be able to refer to the reserved locations, the DB directive should be preceded by a label.

The DB directive takes a list of expressions, and must contain at least one expression. The DB directive must be placed in a Code Segment or an EEPROM Segment.

The expression list is a sequence of expressions, delimited by commas. Each expression must evaluate to a number between -128 and 255. If the expression evaluates to a negative number, the 8 bits two’s complement of the number will be placed in the program memory or EEPROM memory location.

If the DB directive is used in a Code Segment and the expression list contains more than one expression, the expressions are packed so that two bytes are placed in each program memory word. If the expression list contains an odd number of expressions, the last expression will be placed in a program memory word of its own, even if the next line in the assembly code contains a DB directive.

Syntax:

\[ \text{LABEL: .DB expressionlist} \]

Example:

```
.CSEG
consts: .DB 0, 255, 0b01010101, -128, 0xaa
.ESEG
econst:.DB 0xff
```

4.5.4 **DEF - Set a symbolic name on a register**

The DEF directive allows the registers to be referred to through symbols. A defined symbol can be used in the rest of the program to refer to the register it is assigned to. A register can have several symbolic names attached to it. A symbol can be redefined later in the program.

Syntax:

\[ \text{.DEF Symbol=Register} \]

Example:

```
.DEF temp=R16
.DEF ior=R0
.CSEG
ldi temp,0xf0 ; Load 0xf0 into temp register
in ior,0x3f ; Read SREG into ior register
eor temp,ior ; Exclusive or temp and ior
```
The DEVICE directive allows the user to tell the Assembler which device the code is to be executed on. If this directive is used, a warning is issued if an instruction not supported by the specified device occurs in the code. If the size of the Code Segment or EEPROM Segment is larger than supported by the specified device, a warning is issued. If the DEVICE directive is not used, it is assumed that all instructions are supported and that there are no restrictions on memory sizes.

**Syntax:**

```
.DEVICE AT90S1200 | AT90S2313 | AT90S4414 | AT90S8515
```

**Example:**

```
.DEVICE AT90S1200

.CSEG

push r30 ; This statement will generate a warning since the specified device does not have this instruction
```

The DSEG directive defines the start of a Data Segment. An Assembler file can consist of several Data Segments, which are concatenated into one Data Segment when assembled. A Data Segment will normally only consist of BYTE directives (and labels). The Data Segments have their own location counter which is a byte counter. The ORG directive (see description later in this document) can be used to place the variables at specific locations in the SRAM. The directive does not take any parameters.

**Syntax:**

```
.DSEG
```

**Example:**

```
.DSEG ; Start data segment

var1:.BYTE 1 ; reserve 1 byte to var1

.CSEG

ldi r30,low(var1) ; Load Z register low

ldi r31,high(var1) ; Load Z register high

ld r1,Z ; Load var1 into register 1
```
4.5.7 DW-Define constant word(s) in program memory or E2PROM memory

The DW directive reserves memory resources in the program memory or EEPROM memory. In order to be able to refer to the reserved locations, the DW directive should be preceded by a label.

The DW directive takes a list of expressions, and must contain at least one expression.

The DB directive must be placed in a Code Segment or an EEPROM Segment.

The expression list is a sequence of expressions, delimited by commas. Each expression must evaluate to a number between -32768 and 65535. If the expression evaluates to a negative number, the 16 bits two's complement of the number will be placed in the program memory location.

Syntax:

```
LABEL: .DW expressionlist
```

Example:

```
.CSEG
  varlist:.DW 0,0xffff,0b1001110001010101,-32768,65535
.ESEG
  eev: .DW 0xffff
```

4.5.8 ENDMACRO - End macro

The ENDMACRO directive defines the end of a Macro definition. The directive does not take any parameters. See the MACRO directive for more information on defining Macros.

Syntax:

```
.ENDMACRO
```

Example:

```
.MACRO SUBI16 ; Start macro definition
           subi r16,low(@0) ; Subtract low byte
           sbci r17,high(@0) ; Subtract high byte
.ENDMACRO ; End macro definition
```

4.5.9 EQU - Set a symbol equal to an expression

The EQU directive assigns a value to a label. This label can then be used in later expressions. A label assigned to a value by the EQU directive is a constant and can not be changed or redefined.

Syntax:

```
.EQU label = expression
```

Example:

```
.EQU io_offset = 0x23
.EQU porta = io_offset + 2
.CSEG ; Start code segment
  clr r2 ; Clear register 2
  out porta,r2 ; Write to Port A
```
The ESEG directive defines the start of an EEPROM Segment. An Assembler file can consist of several EEPROM Segments, which are concatenated into one EEPROM Segment when assembled. The BYTE directive cannot be used within an EEPROM Segment. The EEPROM Segments have their own location counter which is a byte counter. The ORG directive (see description later in this document) can be used to place constants at specific locations in the EEPROM memory. The directive does not take any parameters.

Syntax:
```
.ESEG
```

Example:
```
.DSEG

vartab: .BYTE 4

.ESEG

eeval: .DW 0xff0f

.CSEG

const: .DW 2

mov r1,r0
```

The EXIT directive tells the Assembler to stop assembling the file. Normally, the Assembler runs until end of file (EOF). If an EXIT directive appears in an included file, the Assembler continues from the line following the INCLUDE directive in the file containing the INCLUDE directive.

Syntax:
```
.EXIT
```

Example:
```
.EXIT
```

The INCLUDE directive tells the Assembler to start reading from a specified file. The Assembler then assembles the specified file until end of file (EOF) or an EXIT directive is encountered. An included file may itself contain INCLUDE directives.

Syntax:
```
.INCLUDE "filename"
```

Example:
```
; iodefs.asm:

.EQU sreg=0x3f
; Status register

.EQU sphigh=0x3e
; Stack pointer high

.EQU splow=0x3d
; Stack pointer low

.in r0,sreg

; INCLUDE "iodefs.asm"
```

; incdemo.asm

; Include I/O definitions

4.5.13 LIST - Turn the listfile generation on

The LIST directive tells the Assembler to turn listfile generation on. The Assembler generates a listfile which is a combination of assembly source code, addresses and opcodes. Listfile generation is turned on by default. The directive can also be used together with the NOLIST directive in order to only generate listfile of selected parts of an assembly source file.

Syntax:

```
.LIST
```

Example:

```
.NLIST ; Disable listfile generation
.INCLUDE "macro.inc" ; The included files will not
.INCLUDE "const.def" ; be shown in the listfile
.LIST ; Reenable listfile generation
```

4.5.14 LISTMAC - Turn macro expansion on

The LISTMAC directive tells the Assembler that when a macro is called, the expansion of the macro is to be shown on the listfile generated by the Assembler. The default is that only the macro-call with parameters is shown in the listfile.

Syntax:

```
.LISTMAC
```

Example:

```
.MACRO MACX ; Define an example macro
  add r0,@0 ; Do something
  eor r1,@1 ; Do something
.ENDMACRO ; End macro definition

.LISTMAC ; Enable macro expansion

MACX r2,r1 ; Call macro, show expansion
```

4.5.15 MACRO - Begin macro

The MACRO directive tells the Assembler that this is the start of a Macro. The MACRO directive takes the Macro name as parameter. When the name of the Macro is written later in the program, the Macro definition is expanded at the place it was used. A Macro can take up to 10 parameters. These parameters are referred to as @0-@9 within the Macro definition. When issuing a Macro call, the parameters are given as a comma separated list. The Macro definition is terminated by an ENDMACRO directive.

By default, only the call to the Macro is shown on the listfile generated by the Assembler. In order to include the macro expansion in the listfile, a LISTMAC directive must be used. A macro is marked with a + in the opcode field of the listfile.

Syntax:

```
.MACRO macroname
```

Example:

```
.MACRO SUBI16 ; Start macro definition
  subi @1,low(@0) ; Subtract low byte
  sbci @2,high(@0) ; Subtract high byte
.ENDMACRO ; End macro definition

.CSEG ; Start code segment

SUBI16 0x1234,r16,r17; Sub.0x1234 from r17:r16
```
The NLIST directive tells the Assembler to turn listfile generation off. The Assembler normally generates a listfile which is a combination of assembly source code, addresses and opcodes. Listfile generation is turned on by default, but can be disabled by using this directive. The directive can also be used together with the LIST directive in order to only generate listfile of selected parts of an assembly source file.

Syntax:
```
.NOLIST ; Enable listfile generation
```

Example:
```
.NOLIST ; Disable listfile generation
.INCLUDE "macro.inc" ; The included files will not be shown in the listfile
.INCLUDE "const.def"
.LIST ; Reenable listfile generation
```

The ORG directive sets the location counter to an absolute value. The value to set is given as a parameter. If an ORG directive is given within a Data Segment, then it is the SRAM location counter which is set, if the directive is given within a Code Segment, then it is the Program memory counter which is set and if the directive is given within an EEPROM Segment, then it is the EEPROM location counter which is set. If the directive is preceded by a label (on the same source code line), the label will be given the value of the parameter. The default values of the Code and EEPROM location counters are zero, whereas the default value of the SRAM location counter is 32 (due to the registers occupying addresses 0-31) when the assembling is started. Note that the EEPROM and SRAM location counters count bytes whereas the Program memory location counter counts words.

Syntax:
```
.ORG expression
```

Example:
```
.DSEG ; Start data segment
.ORG 0x67 ; Set SRAM address to hex 67
variable:.BYTE 1 ; Reserve a byte at SRAM

.ESEG ; Start EEPROM Segment
.ORG 0x20 ; Set EEPROM location
eevar: .DW 0xfeff ; Initialize one word

.CSEG
.ORG 0x10 ; Set Program Counter to hex 10
mov r0,r1 ; Do something
```
4.5.18 SET - Set a symbol equal to an expression

The SET directive assigns a value to a label. This label can then be used in later expressions. A label assigned to a value by the SET directive can be changed later in the program.

Syntax:

```
.SET label = expression
```

Example:

```
.SET io_offset = 0x23
.SET porta = io_offset + 2
.CSEG ; Start code segment
clr r2 ; Clear register 2
out porta, r2 ; Write to Port A
```

4.6 Expressions

The Assembler incorporates expressions. Expressions can consist of operands, operators and functions. All expressions are internally 32 bits.

4.6.1 Operands

The following operands can be used:

- User defined labels which are given the value of the location counter at the place they appear.
- User defined variables defined by the SET directive
- User defined constants defined by the EQU directive
- Integer constants: constants can be given in several formats, including
  a) Decimal (default): 10, 255
  b) Hexadecimal (two notations): 0x0a, $0a, 0xff, $ff
  c) Binary: 0b00001010, 0b11111111
- PC - the current value of the Program memory location counter

4.6.2 Functions

The following functions are defined:

- LOW(expression) returns the low byte of an expression
- HIGH(expression) returns the second byte of an expression
- BYTE2(expression) is the same function as HIGH
- BYTE3(expression) returns the third byte of an expression
- BYTE4(expression) returns the fourth byte of an expression
- LWRD(expression) returns bits 0-15 of an expression
- HWRD(expression) returns bits 16-31 of an expression
- PAGE(expression) returns bits 16-21 of an expression
- EXP2(expression) returns 2^expression
- LOG2(expression) returns the integer part of log2(expression)

4.6.3 Operators

The Assembler supports a number of operators which are described here. The higher the precedence, the higher the priority. Expressions may be enclosed in parentheses, and such expressions are always evaluated before combined with anything outside the parentheses.
4.6.3.1 Logical Not
Symbol: !
Description: Unary operator which returns 1 if the expression was zero, and returns 0 if the expression was nonzero
Precedence: 14
Example: ldi r16,!0xf0 ; Load r16 with 0x00

4.6.3.2 Bitwise Not
Symbol: ~
Description: Unary operator which returns the input expression with all bits inverted
Precedence: 14
Example: ldi r16,~0xf0 ; Load r16 with 0x0f

4.6.3.3 Unary Minus
Symbol: -
Description: Unary operator which returns the arithmetic negation of an expression
Precedence: 14
Example: ldi r16,-2 ; Load -2(0xfe) in r16

4.6.3.4 Multiplication
Symbol: *
Description: Binary operator which returns the product of two expressions
Precedence: 13
Example: ldi r30,label*2 ; Load r30 with label*2

4.6.3.5 Division
Symbol: /
Description: Binary operator which returns the integer quotient of the left expression divided by the right expression
Precedence: 13
Example: ldi r30,label/2 ; Load r30 with label/2

4.6.3.6 Addition
Symbol: +
Description: Binary operator which returns the sum of two expressions
Precedence: 12
Example: ldi r30,c1+c2 ; Load r30 with c1+c2

4.6.3.7 Subtraction
Symbol: -
Description: Binary operator which returns the left expression minus the right expression
Precedence: 12
Example: ldi r17,c1-c2 ; Load r17 with c1-c2

4.6.3.8 Shift left
Symbol: <<
Description: Binary operator which returns the left expression shifted left a number of times given by the right expression
Precedence: 11
Example: ldi r17,1<<bitmask ; Load r17 with 1 shifted left bitmask times
4.6.3.9  Shift right
Symbol:  >>
Description: Binary operator which returns the left expression shifted right a number of times given by the right expression.
Precedence:  11
Example: ldi r17,c1>>c2 ;Load r17 with c1 shifted right c2 times

4.6.3.10  Less than
Symbol:  <
Description: Binary operator which returns 1 if the signed expression to the left is Less than the signed expression to the right, 0 otherwise
Precedence:  10
Example: ori r18,bitmask*(c1<c2)+1 ;Or r18 with an expression

4.6.3.11  Less or Equal
Symbol:  <=
Description: Binary operator which returns 1 if the signed expression to the left is Less than or Equal to the signed expression to the right, 0 otherwise
Precedence:  10
Example: ori r18,bitmask*(c1<=c2)+1 ;Or r18 with an expression

4.6.3.12  Greater than
Symbol:  >
Description: Binary operator which returns 1 if the signed expression to the left is Greater than the signed expression to the right, 0 otherwise
Precedence:  10
Example: ori r18,bitmask*(c1>c2)+1 ;Or r18 with an expression

4.6.3.13  Greater or Equal
Symbol:  >=
Description: Binary operator which returns 1 if the signed expression to the left is Greater than or Equal to the signed expression to the right, 0 otherwise
Precedence:  10
Example: ori r18,bitmask*(c1>=c2)+1 ;Or r18 with an expression

4.6.3.14  Equal
Symbol:  ==
Description: Binary operator which returns 1 if the signed expression to the left is Equal to the signed expression to the right, 0 otherwise
Precedence:  9
Example: andi r19,bitmask*(c1==c2)+1 ;And r19 with an expression
4.6.3.15 Not Equal
Symbol: !=
Description: Binary operator which returns 1 if the signed expression to the left is Not Equal to the signed expression to the right, 0 otherwise
Precedence: 9
Example: .SET flag=(c1!=c2) ;Set flag to 1 or 0

4.6.3.16 Bitwise And
Symbol: &
Description: Binary operator which returns the bitwise And between two expressions
Precedence: 8
Example: ldi r18,High(c1&c2) ;Load r18 with an expression

4.6.3.17 Bitwise Xor
Symbol: ^
Description: Binary operator which returns the bitwise Exclusive Or between two expressions
Precedence: 7
Example: ldi r18,Low(c1^c2) ;Load r18 with an expression

4.6.3.18 Bitwise Or
Symbol: |
Description: Binary operator which returns the bitwise Or between two expressions
Precedence: 6
Example: ldi r18,Low(c1|c2) ;Load r18 with an expression

4.6.3.19 Logical And
Symbol: &&
Description: Binary operator which returns 1 if the expressions are both nonzero, 0 otherwise
Precedence: 5
Example: ldi r18,Low(c1&&c2) ;Load r18 with an expression

4.6.3.20 Logical Or
Symbol: ||
Description: Binary operator which returns 1 if one or both of the expressions are nonzero, 0 otherwise
Precedence: 4
Example: ldi r18,Low(c1||c2) ;Load r18 with an expression
4.7 Microsoft Windows specifics

This section describes the features specific to WAVRASM. Only the menu items specific to the Assembler are described. It is assumed that the user is familiar with the “Search” and “Window” menu items. A typical editing session with the Assembler is shown in the following figure.

4.7.1 Opening Assembly Files

A new or existing assembly files can be opened in WAVRASM. Theoretically there is no limit on how many assembly files which can be open at one time. The size of each file must be less than about 28K bytes due to a limitation in MS-Windows. It is still possible to assemble files larger than this, but they can not be edited in the integrated editor. A new editor window is created for every assembly file which is opened.

To create a new assembly file click the button on the toolbar or choose “File → New” (ALT-F N) from the menu. To open an existing file click the button on the toolbar or choose “File → Open” (ALT-F O) from the menu.

4.7.2 The Integrated Editor

When WAVRASM is finished loading a file, the text editor will be inactive. Refer to the section on opening files on how to open a file. Right after a file is loaded into an editor window of the Assembler, the insertion point appears in the upper left corner of the window.

4.7.3 Typing and Formatting Text

The insertion point moves to the right when typing. If text is written beyond the right margin, the text automatically scrolls to the left so that the insertion point is always visible.

4.7.4 Moving the Insertion Point

The insertion point can be moved anywhere by moving the mouse cursor to the point where the insertion point is wanted and click the left button.
To move the insertion point with the keyboard, use the following keys or key combinations:

<table>
<thead>
<tr>
<th>To move the insertion point:</th>
<th>Press:</th>
</tr>
</thead>
<tbody>
<tr>
<td>to the right in a line of text</td>
<td>Right arrow key</td>
</tr>
<tr>
<td>to the left in a line of text</td>
<td>Left arrow key</td>
</tr>
<tr>
<td>up in a body of text</td>
<td>Up arrow key</td>
</tr>
<tr>
<td>down in a body of text</td>
<td>Down arrow key</td>
</tr>
<tr>
<td>to the beginning of a line of text</td>
<td>Home</td>
</tr>
<tr>
<td>to the end of a line of text</td>
<td>End</td>
</tr>
<tr>
<td>to the beginning of the file</td>
<td>Ctrl+Home</td>
</tr>
<tr>
<td>to the end of the file</td>
<td>Ctrl+End</td>
</tr>
</tbody>
</table>

### 4.7.5 Formatting Text

The keys in the table below describes the necessary operations to type in the text exactly as wanted.

<table>
<thead>
<tr>
<th>To:</th>
<th>Press:</th>
</tr>
</thead>
<tbody>
<tr>
<td>insert a space</td>
<td>Spacebar</td>
</tr>
<tr>
<td>delete a character to the left</td>
<td>Backspace</td>
</tr>
<tr>
<td>delete a character to the right</td>
<td>Del</td>
</tr>
<tr>
<td>end a line</td>
<td>Enter</td>
</tr>
<tr>
<td>indent a line</td>
<td>Tab</td>
</tr>
<tr>
<td>insert a tab stop</td>
<td>Tab</td>
</tr>
</tbody>
</table>

To split a line, move the insertion point to the position where the break is wanted and press Enter.

To join two lines, move the insertion point to the beginning of the line to move, and press Backspace. The editor joins the line with the line above.

### 4.7.6 Scrolling

If a line of text is longer or wider than can be shown at one time, the file can be scrolled by using the scroll bars.

### 4.7.7 Editing Text

The Edit-menu contains some functions which can be of much help in editing. Text can be deleted, moved or copied to new locations. The Undo command can be used to revert the last edit. Transferring text to and from other windows or applications can be done via the clipboard. When text is deleted or copied with the commands Cut or Copy, the text is placed in the Clipboard. The Paste command copies text from the Clipboard to the editor.

### 4.7.8 Selecting Text

Before a command is selected from the Edit-menu to edit text, the text to operate on must first be selected.

Selecting text with the keyboard:

1. Use the arrow keys to move the insertion point to the beginning of the text to select.
2. Press and hold the Shift-key while moving the insertion point to the end of the text to select. Release the Shift-key. To cancel the selection, press one of the arrow keys.
Selecting text with the mouse:
1. Move the mouse cursor to the beginning of the text to select.
2. Hold down the left mouse button while moving the cursor to the end of the text to select. Release the mouse button.
3. To cancel the selection, press the left mouse button or one of the arrow keys.

4.7.9 Replacing Text
When text is selected, it can be immediately replaced it by typing new text. The selected text is deleted when the first new character is typed.

Replacing text:
1. Select the text to replace.
2. Type the new text.

Deleting Text:
1. Select the text to delete.
2. Press the Del key.

To restore the deleted text, press the key on the toolbar or choose “Edit → Undo” (Alt+Backspace) from the menu immediately after deleting the text.

4.7.10 Moving Text
Text can be moved from one location in the editor by first copy the text to the Clipboard with the Cut command, and then pasting it to its new location using the Paste command.

To move text:
1. Select the text to move.
2. Press the button on the toolbar or choose “Edit → Cut” (Shift+Del) from the menu. The text is placed in the Clipboard.
3. Move the insertion point to the new location.
4. Press the button on the toolbar or choose “Edit → Paste” (Shift+Ins) from the menu.

4.7.11 Copying Text
If some text will be used more than once, it need not be typed each time. The text can be copied to the Clipboard with Copy, and can then be pasted in many places by using the Paste command.

To copy text:
1. Select the text to copy.
2. Click the button on the toolbar or choose “Edit → Copy” (Ctrl+Ins) from the menu. The text is placed in the Clipboard.
3. Move the insertion point to the location to place the text.
4. Click the button on the toolbar or choose “Edit → Paste” (Shift-Ins) from the menu.

4.7.12 Undoing an Edit
The Undo command can be used to cancel the last edit. For example, text may accidentally have been deleted, or it has been copied to a wrong location. If the Undo command is chosen immediately after the mistake was done, the text will be restored to what it was before the mistake.

To undo the last edit click the button on the toolbar or choose “Edit → Undo” (Alt+Backspace) from the menu.

4.7.13 Click On Errors
The Assembler has a click on error function. When a program is assembled, a message window appears on the screen. If errors are encountered, the errors are listed in this message window. If one of the error lines in the message window is clicked, the source line turns inverted red. If the error is in a included file, nothing happens.
This feature is demonstrated in the following figure:

If the message window line is doubleclicked, the file containing the error becomes the active window, and the cursor is placed at the beginning of the line containing the error. If the file containing the error is not opened (for instance an included file), then the file is automatically opened.

Note that this function points to lines in the assembled file. This means that if lines are added or removed in the source file, the file must be reassembled in order to get the line numbers right.

4.7.14 Setting Program Options

Some of the default values of WAVRASM can be changed in the options menu. If “Options” is selected on the menu bar, the following dialog box pops up.
In the box labeled “List-file extension” the default extension on the list file(s) is written, and in the box labeled “Output-file extension” the default extension of the output file is written. In the box labeled “Output file format” the type of format wanted on the output file can be selected. If the OK button is clicked, the values are remembered in subsequent runs of the Assembler. Note that the object file (used by the simulator) is not affected by these options; the extension of the object file is always ‘OBJ’ and the format is always the same. If an EEPROM Segment has been defined in the code, the assembler will also generate a file with extension ‘EEP’ which is the initial values for the EEPROM memory. This EEPROM initialization file is in the same format as the Output file format selected.

The “Wrap relative jumps” option tells the Assembler to use wrapping of addresses. This feature is only useful when assembling for devices with 4K words of program memory. Using this option on such devices, the relative jump and call instructions will reach the entire program memory.

The “Save before assemble” option makes the Assembler automatically save the contents of the editor before assembling is done.

4.8 Command line version

For the MS-DOS command line version the Assembler is invoked by the command

```
AVRASM [-m | -i | -g][-w] input.asm output.lst output.rom
```

AVRASM will now read source from input.asm, produce the listfile output.lst, output.rom and the object file input.obj. The objectfile '*.obj' is used by the MS-Windows simulator.

The user can select which output format to generate by using one of the options -m (Motorola S-record), -i (Intel Hex) or -g (Generic). The Generic file format is used by default.

The -w option tells the Assembler to use wrapping of addresses. This feature is only used when assembling for devices with 4K words of program memory. Using this switch on these devices, the relative jump and call instructions will reach the entire program memory.